using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([^);]+)";
string input = @"1. yada yada yada (This is a string; ""This is a thing"")
2. blah blah blah (This is also a string)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}