$re = '/\b\d{1,3}(?:\.\d{3})*,\d+\b/';
$str = '|C195|1|Base de Cálculo ST: 2.608,24 - Valor da ST: 2.608.234,24 12.608.234,24
163,66|
d2.608.234,24
2.60d8.23d4,24';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);