$re = '/^(([a-z0-9\s]+\/)+)?([a-z0-9\s]+)\.[a-z]+/mi';
$str = 'Documents/OneDrive/Collections/book.xlsx
Documents/OneDrive/Collections/book.xls
Documents/OneDrive/Collections/book.xlsm
book 2.xls
aa.xlsx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);