$re = '/^\/(.*&d=.*)$/';
$str = '/18AhPyB&p=CdATyJnFMw1gl9Z';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);