$re = '/\B(?=(\d{8})+(?!\d))/';
$str = '123456781';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);