$re = '/(?<=\{)[^}]+(?=\})/';
$str = '{t} this text shouldn\'t {1}{2} be captured {3}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);