package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b0[1-9]|1[012]\b`)
var str = `00 01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 40 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}