$re = '/(?:_|\b)\K[0-9]+(?=_|\b)/m';
$str = 'Trailer ep_01_720p.mp4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);