const regex = /(?i)rama:.*\K(\{[^\}]*\})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)rama:.*\\K(\\{[^\\}]*\\})', '')
const str = `Mon Feb 09 20:07:43 PKT 2015: VerifyPdb.Rama: Status: FINISHEDPART | Message: {fep=98.0, op=3.0, ac=6.0, ap=9.0}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}