re = /^([A-Z0-9a-z_&\+\*\=\(\)\.\%\/\<\>\|\-\?\=\:\,\´\'\&\#\;\sàèìòù]{6,3000})$/
str = '
• esprimere dissensi ovvero effettuare reclami.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end