using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/apps/files(/.*)?";
string input = @"/apps/files_xxx/index.php";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}