$re = '/(?<one>[1-9])\-(?<two>\1)/';
$str = '8-8';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);