package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<one>[1-9])\-(?<two>\g{one})`)
var str = `8-8`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}