#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*[.](?:js|ico|gif|jpg|png|css|rss|xml|htm|html|pdf|zip|gz|txt|ttf|woff)$).*$"
Local $sString = "http://gioplet/articles" & @CRLF & _
"http://gioplet/img/logo.png" & @CRLF & _
"http://gioplet/index.php" & @CRLF & _
"http://gioplet/css/main.css" & @CRLF & _
"http://gioplet/.css/main" & @CRLF & _
"http://gioplet/.png/main" & @CRLF & _
"http://gioplet/main/index.html" & @CRLF & _
"http://gioplet/js/main.js"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")