re = /^(?!.*\\.integration\\.).*$/m
str = '"test:integration": "jest .*\\\\.integration\\\\..*"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end