$re = '/.*(?<!\S)test\h*\(.*/m';
$str = 'test() function
This is a test() function
This is a test () function
test()
test ()
test(
atest()
atest ()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);