re = /^(?!ThermoControl).*StreamBoundary/m
str = 'ThermoControl
StreamBoundary
TTasdfasdfas
asdfasdf
asdfasdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end