package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(http|https):\/\/[\w\d]+\.[\w]+(\/[\w\d]+)$`)
var str = `https://www.Somnu.comasd`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}