package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[\p{L}\s.’\-,]+$`)
var str = `Bruce Schneier
Schneier, Bruce
Schneier, Bruce Wayne
O’Malley, John F.
John O’Malley-Smith
Cher`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}