import re
regex = re.compile(r"^[A-Z]+[ \t]+[A-Z]+[ \t]+\d+.*[ \t]+[A-Z]{2}[ \t]+\d{5}(?:-\d{4})$", flags=re.MULTILINE)
test_str = ("WILLIAM SMITH 2345 GLENDALE DR RM 245 ATLANTA GA 30328-3474\n"
"LINDSAY SCARPITTA 655 W GRACE ST APT 418 CHICAGO IL 60613-4046")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")