re = /(comment_id=)(\d+)\|(\d+)\|([^|]+)\|([^|]+)\|(\d+)/
str = 'comments={ts=2010-02-09T04:05:20.777+0000,comment_id=529590|2886|LOL|Baoping Wu|529360}
comments={ts=2010-02-09T04:20:53.281+0000, comment_id=529589|2886|cool|Baoping Wu|529360}
comments={ts=2010-02-09T05:19:19.802+0000,comment_id=529591|2886|ok|Baoping Wu|529360}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end