#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([A-Z][a-z]+)+((__([a-z]+[A-Z]?)+)(--([a-z]+[A-Z]?)+)?)?$"
Local $sString = "TitleCaseName" & @CRLF & _
"" & @CRLF & _
"TitleCaseName__element" & @CRLF & _
"" & @CRLF & _
"TitleCaseName__element--modifier" & @CRLF & _
"" & @CRLF & _
"TitleCaseName--modifier" & @CRLF & _
"" & @CRLF & _
"TitleCaseName__element__modifier"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")