re = /^(?!.*[.][.])[A-Za-z0-9][A-Za-z0-9._-]+[A-Za-z0-9]@[A-Za-z0-9][A-Za-z0-9.-]+.[A-Za-z0-9.-]+[A-Za-z0-9]$/m
str = 'asd.asd@asd.com
asd..asd@asd.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end