$re = '/^([a-z]+\:)\/*([^\/\s\?]*)(\?[a-z0-9\-@\^=%&;\/~\+]*)*[\?]?([^ \#]*)#?([^ \#]*)/i';
$str = 'http:///evil-phisher/foo.html#h\\\\a\\\\s\\\\h';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);