re = /(^.*?)([\w-]+(?:\.[\w-]+)*@(?:[\w-]+\.)+[a-zA-Z]{2,})
/m
str = 'Greg Reichow <gdr@me.com>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end