import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+";
final String string = " The First 1,000,000 Primes (from primes.utm.edu)\n\n\n\n"
+ " 2 3 5 7 11 13 17 19 \n\n"
+ " 23 29 31 37 41 43 47 53 \n\n"
+ " 59 61 67 71 73 79 83 89 \n\n"
+ " 97 101 103 107 109 113 127 131 \n\n"
+ " 137 139 149 151 157 163 167 173 \n\n"
+ " 179 181 191 193 197 199 211 223 \n\n"
+ " 227 229 233 239 241 251 257 263 \n\n"
+ " 269 271 277 281 283 293 307 311 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}