re = /(?P<type>ENNI)(?:::)(?P<ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}|_)?(?:::)(?P<desc>[\w#()\/-]*)?/m
str = 'ENNI::10.240.20.10::SHARED_ENNI'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end