re = /(\skeyword\s|\skey\s|\s(?=.*[\[{]|[^\]}]+$))/m
str = '[] []
[] keyword []
[] key []
[] ["can contain spaces"]
[] keyword ["can contain spaces"]
[] key ["can contain spaces"]
{} {}
{} keyword {}
{} key {}
{} {"can":"contain spaces"}
{} keyword {"can":"contain spaces"}
{} key {"can":"contain spaces"}
string string
string keyword string
string key string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end