package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\/[\w-]+)+(.[a-zA-Z]+?)$`)
var str = `/usr/share/ovirt-plugin/password-test.txt`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}