import re
regex = re.compile(r"(?:account:(.+))(?:site:(.+))(?:zone:(.+))-->|(?:site:(.+))(?:zone:(.+))(?:size:(.+))\s+-->|(?:placement:(.+))-->", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("<!-- Account: QA 1 Test Site: Video Test Site for Mobile Team (Nitin) Zone: ROS -->\n"
"http://optimized-by.rubiconproject.com/a/api/vast.xml?account_id=2763&site_id=40876&zone_id=170462 \n\n"
"<!-- Begin Rubicon Project Tag -->\n"
"<!-- Site: DOM_TOLIVER_MWEB Zone: Interstitials Size: Mobile Interstitial Landscape -->\n"
"<!-- PLACEMENT: Homepage; Above the Fold -->\n"
"<script language=\"JavaScript\" type=\"text/javascript\">\n"
"rp_account = '8092';\n"
"rp_site = '55880';\n"
"rp_zonesize = '340088-101';\n"
"rp_adtype = 'js';\n"
"rp_smartfile = '[SMART FILE URL]';\n"
"</script>\n"
"<script type=\"text/javascript\" src=\"http://ads.rubiconproject.com/ad/8092.js\"></script>\n"
"<!-- End Rubicon Project Tag -->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")