re = /%(?:\\.|[^" %\d\\])*%/
str = '"The files under users\\%username%\\desktop\\ are:"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end