using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.+?)(?:,\1)+\)";
string input = @"(A,B,C,A,B,C,A,B,C,A,B,C)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}