re = /^(?!(?:0(?:\.0){3}|255(?:\.255){3})$)([01]?\d\d?|2[0-4]\d|25[0-5])\.([01]?\d\d?|2[0-4]\d|25[0-5])\.([01]?\d\d?|2[0-4]\d|25[0-5])\.([01]?\d\d?|2[0-4]\d|25[0-5])$/m
str = '100.1.2.3
0.0.0.0
0.0.0.1
255.255.255.254
255.255.255.255
255.255.255.256'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end