re = /(^|\s)(?!\w*aa\w*)(\w+)/i
str = 'net baa cec haw ddd baas bat jackaay lut baa leenat fat faaa tar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end