re = /((https?):\/\/(?:www\.)?([\w\.\-\:]+)(?:\/(.+))?)/
str = 'http://11.111.111.1:1010/nexus-2.3.1/service/local/artifact/maven/content?r=fake_release&g=com.fake&a=com.rake.fake.soap.webapp&v=LATEST&e=war
https://hello-ci.fake-re.com/jenkins/view/RAS/job/RAS_Designtime_Master/site/com.rake.fake.ras.documentation/kwl/Assessment-faker-gage.html
https://regex101.com/#python
https://www.google.com
http://www.apple.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end