$re = '/[^A]*/m';
$str = 'AA4grgrsragrga4334grAA
AAA4323425AAA
AAAAAA%%%AAAAAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);