$re = '/<\/sup>(.*)<\/div>/m';
$str = '</sup></sup>dsadsads</div>
</sup>dsadsadsa</div></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);