$re = '/^.*Foo\w*\(+.*$/mi';
$str = 'int Foo(char);
int Foo()
{
//do something
}
int FooBar(char, char);
foo.Get();
fooBar.Get();
m_FooBar.Get();
case foo:
fooBar(x,y);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);