import Foundation
let pattern = #"(?<=\b[A-Z])O\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Abc JO SOO Xyz"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)