const regex = /^(?!.*?([A-Za-z])\1{3})\S+\s+\S+\s+\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*?([A-Za-z])\\1{3})\\S+\\s+\\S+\\s+\\S+', 'gm')
const str = `Word1 word2 word3
Word1 wwwword2 word3
Word1 word2 word3 word4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}