$re = '/^0*?[1-9]\d*$/';
$str = '0111111111111';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);