$re = '/(99|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9])/';
$str = '9923';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);