$re = '/(\w*\S*[\S*])/m';
$str = 'This is a test!! @test_twitter #testForLife';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);