import Foundation
let pattern = #"^.*IMAP Error: Login failed for .* from (?P<host>.*)\. AUTHENTICATE PLAIN: Authentication failed\. in .* \(POST .*\)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[16-Sep-2016 17:48:15 +0200]: <r24n59kn> IMAP Error: Login failed for ssdfsdf from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:48:28 +0200]: <r24n59kn> IMAP Error: Login failed for ssdfsdf from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:48:47 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:49:12 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:49:39 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:50:23 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)