$re = '/(\((?:[^()]+|(?1))+\))\s+/';
$str = '(030334-999N)\'';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;