re = /(?=.*[0-9])(?=.*[!@#$%^&*])(?=.*[a-z])(?=.*[A-Z])[0-9a-zA-Z!@#$%^&*]{6,}/
str = 'a0A#ccsxcvx
fkI3kcm
aKf0$
Ld0smZNdr9cm!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end