re = />>[^>]+$/
str = 'Opportunity >> Source = Email >> Status = New >> Branch = Mumbai'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end