re = /\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\//
str = '/*
* Some text here
*/
/**/ Incorrectly removed /**/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end