use strict;
my $str = 'comments={ts=2010-02-09T04:05:20.777+0000, comment_id=529590, user_id = 2886, comment=\'LOL\', user= \'Baoping Wu\', post_commented=529360}';
my $regex = qr/comment_id=.*?(?=,)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}