package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[AC-FHKNPRTV-Y]{1}[0-9]{1}[0-9W]{1}[ \-]?[0-9AC-FHKNPRTV-Y]{4}$`)
var str = `D24 FT12
D22 TF12
D24 TF13
A65 TF12
B32 AC21
D21 3333
D6W 3333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}